8th April 2019

SureDone Primary Application Database Performance Issue

UPDATE (6:58PM ET): We've failed over to a secondary DB server and all systems are back up as of 6:50PM ET. We'll be doing a postmortem analysis with the AWS team to figure out why this happened outside our planned restart window. We no longer expect to restart the system at 3:00AM Eastern.

UPDATE (6:45PM ET): The performance issue has caused a restart of our primary DB server early than planned. We expect 20-30 minute outage from 6:40PM ET.

We are working with our database vendor to resolve a performance issue and will need to restart our main database at 3:00AM Eastern. We expect our entire system to be unavailable for up to 20 minutes during this period.